Security News
긴급도 25/100 심각도 9.8 · 치명적 악용확률 72.2% CWE-917

CVE-2026-104711

Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected.

This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
타임라인
  1. NVD 공개
  2. 첫 보도 The Hacker News · ⚡ 주간 요약: 헬프데스크 제로데이, 위조 인증서, ShinyHunter…

날짜 정보 없는 신호: 공개 PoC 9건

벡터: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

공개 익스플로잇 / PoC

NVD 상세 ↗   벤더 권고문 ↗   참고 링크 ↗

이 취약점을 다룬 기사 (1)

← 취약점 목록